Bolts won't follow

Hi,
I’m trying to get my girlfriend’s Bolt to follow mine but hers seems to want to drive -90 degrees as mine moves forward. Is there anything stupid I could be doing?

Essentially mine just has the broadcast code at the start of the program and hers has the follow code only.

I just can’t get it to work!

Thanks for any help. Can do a video if needed.

1 Like

Hello @Declan,

Welcome to the forum!

Can you show me the code you are using on bot devices?
How were you able to drive the your robot? There are currently no options to drive and run a program at the same time.

Any information you can provide would help!

Thanks,

Quentin

1 Like

Hi Quentin,

Thanks for the reply. Here is the code on my bot (the one being followed).
When I said ‘drives’ I didn’t mean the drive mode, just that the robot moves.

async function startProgram() {
startIRBroadcast(0, 1);
while (true) {
await scrollMatrixText(‘HELLO’, { r: 186, g: 216, b: 255 }, 15, false);
await roll(0, 100, 1);
await delay(10);
await roll(90, 100, 1);
await delay(10);
await scrollMatrixText(‘WORLD’, { r: 255, g: 47, b: 69 }, 15, false);
await roll(180, 100, 1);
await delay(10);
await roll(270, 100, 1);
await delay(10);
await delay(0.025);
}
}

G/f’s bot:

async function startProgram() {
startIRFollow(0, 1);
}

When mine makes the first 0 degrees move, hers (which obviously is tracking mine because it stops rotating) dives off to the left.

Thanks for your help.

1 Like

Hello @Declan,

Can you try swapping the robots that are followed / broadcasting?
Would you be able to send a video of your bots and how the second always go left?
I will test this on my own robots.

Thanks!

1 Like

Hi Quentin,

Yes certainly. I will do it over the weekend.

Thanks for the help.

1 Like