Can't Receive Information from RVR with Python

HI All,

I can run the following script.
However, I just get “Checking RVR firmware versions…” if I run anything in:
getting_started/observer/power or sensor_streaming.
If I run things in getting_started/asyncio, I get this error:
Checking RVR firmware versions…
Traceback (most recent call last):
File “”, line 15, in
File “/home/pi/sphero-sdk-raspberrypi-python/sphero_sdk/asyncio/client/toys/”, line 36, in init
File “/usr/lib/python3.7/asyncio/”, line 584, in run_until_complete
return future.result()
File “/home/pi/sphero-sdk-raspberrypi-python/sphero_sdk/asyncio/client/firmware/”, line 26, in _check_rvr_fw
rvr_nordic_version = await self.__rvr.get_main_application_version(target=SpheroRvrTargets.primary.value, timeout=3)
File “/home/pi/sphero-sdk-raspberrypi-python/sphero_sdk/asyncio/client/toys/”, line 87, in get_main_application_version
return await self._dal.send_command(**command_dict)
File “/home/pi/sphero-sdk-raspberrypi-python/sphero_sdk/asyncio/client/dal/”, line 78, in send_command
File “/home/pi/sphero-sdk-raspberrypi-python/sphero_sdk/asyncio/server/handler/”, line 191, in send_command
await asyncio.shield(asyncio.wait_for(future, timeout=timeout))
File “/usr/lib/python3.7/asyncio/”, line 423, in wait_for
raise futures.TimeoutError()

I would appreciate any suggestions.

After executing the apt update, upgrade, and dist-upgrade, I get the same error messages. It works when I run it on the custom Raspbian image that Sphero provides as long as I don’t run any update or upgrade commands which required editing their fist-time shell script.