Connection problems: no response from RVR

Hi everybody,

I’ve been struggling to connect my RVR to a Raspberry Pi 3b+ for the past weeks. Whatever I do, I get no reaction from the RVR. I also tried with an Arduino and no reaction neither. Does anybody experienced something similar or can help me debug the connection? I’m starting to believe my RVR has some hardware issues.

So far I tried:

  • Downloaded a Raspberry Pi image from Sphero website, followed the Getting started guide and launched the set_all_leds.py script. No reaction
  • Installed a fresh SDK from the github following the guide, launched the set_all_leds.py script. No reaction.
  • Tested the GPIO of the Raspberry Pi and they are all working.
  • Connected an Arduino, and put a simple sample code to light up the leds. No reaction.
  • Contacted the Sphero support but not much help there…

I’m running out of ideas. I would really appreciate some help.

Thanks!

Hi @jhubert,

I’m sorry to hear you’re running into issues with your RVR, hopefully there’s something simple here. Let’s start with a few questions.

  1. Have you updated the firmware on your RVR by connecting it to the Sphero EDU app on Android or iOS? Fresh out of the box, UART and USB access are disabled because RVR did not ship with final firmware. (This may change for future production runs)
  2. Which Arduino board are you using? For USB-serial connections to Arduino boards, we only support boards that use a standard USB CDC implementation. If you’re not using an official Uno R3 board, there’s a good chance there’s a different USB interface such as FTDI, CP210x, or CH340. All of these require special drivers that RVR does not have at this time.
  3. How long is your USB cable? RVR has some aggressive protection circuitry on the USB data lines, which can cause issues with longer USB cables. If you have one, try a short cable (30 cm or less), and make sure that you are using a cable that supports data transfer and not just power. Sometimes cables that come with chargers don’t actually have the data lines connected.

-Jim

Hi Jim,

Thank you for helping me out with this. To answer your questions:

  1. I updated the firmware multiple times through the EDU app. I updated before connecting the arduino or raspberry pi to the RVR. Could it be that the update didn’t work and I received no error?
  2. I’m using the official Arduino UNO R3.
  3. My USB cable is 1.8m for the arduino. I will order a shorter one and try with it. I bought that cable separately and it should be fine for data (USB2.0 high speed rated). With the Raspberry Pi, the USB cable is smaller than 30cm and the jumper cables are also short.

Julien

Hi Jim,

I got a shorter usb cable for the arduino and it fixed the problem. Unexpectedly, it also fixed the problem with the Raspberry Pi. Same cables as I used before, same connection, but it works fine now.

Thanks a lot for your help!
Julien

Well that is strange that it had an effect on the Pi, since it’s only delivering power in that use case, but I’m glad you got everything working.

Have fun!

Jim

SPHERO Email Marketing -