Flashing red RVR

My Sphero RVR is flashing red whenever I have a battery plugged in. I have tested it with two fresh batteries on two different RVR’s; so it is NOT the batteries. I pressed the reset button but to no avail, it hasn’t changed a consistent flashing red. Suggestions for this fix? Reset for a firmware fix? I just unboxed this one.

Confirmed that it was indeed firmware. Problem resolved

1 Like

Hey @ggtechteacher,

Sorry your brand new bot is throwing such a fuss!!

Flashing red can mean a few things:
If it is flashing every second, that would be a low battery indication.
If it is flashing a few times per second, that would be a critical battery indication.
If it is cycling red for two seconds and then off for two seconds, that would be a bad main app version.

If the issue is a bad main app version, connecting to the Edu App on a mobile phone (which should update the corrupt firmware) would fix it.

Please let us know if this helps!

Kelsey

1 Like

Yep. Firmware. Even though the process completed it must have been weak connection because of it being within my school walls.
All is good. I had a video demonstrating the issue but this service doesn’t let us post videos… only pics… will this change?? I hope so because it is the best demonstration of the issue.

Thanks for the tip about the battery level… I’m a bit more advanced than that being the problem. Lol :wink:

1 Like

So happy you got it sorted out, @ggtechteacher!

I figured that the issue was likely not the battery, given your troubleshooting steps, but also used the excuse to document all “red flashing leds” for anyone else who stumbles upon this post; thanks for humoring me, haha :wink:

Hope you have an awesome time with your RVR!!

Kelsey

1 Like