HELP! RVR and Microbit Cannot connect to create Temp Sensor or remote Control driving

HELP! THE OCT. 2nd FOOD PANTRY FUNDRAISER IS IN TROUBLE!!!

Hello, I have completed multiple tutorials with the microbit and the rvr connections. I have checked data cables and read everything in the community files, youtube files, and websites. The mircobit cannot seem to connect to the rover to change led colors with temperature. If these two cannot talk to each other, I cannot have students build remote-controlled Microbit to have the rover play PAC-Man. Please note, we have tried the V1 as well as the V2 Microbits
Please help!!!

I have attached my block


code here.
Thanks, Anne Laughlin-Fuller

Hi Anne,

Sorry I just saw this post, but I tried your code and it worked for me. I do have a few notes though:

  1. The cyan color in the else case is not far off from RVR’s idle animation, which makes it a bit difficult to see that the program is doing anything.
  2. 15C is a pretty low threshold if you’re testing in a room temperature environment. Without sticking the micro:bit in a refrigerator I only hit the else case.

To test your connection, I’d recommend using something that’s more easily observed such as a hard-coded startup LED sequence like this:

If you find with that program that you’re not getting a connection, try a shorter USB cable. We’ve made some hardware changes in the upcoming RVR+ model to allow the use of much longer cables, but the original RVR sometimes has trouble with longer cables. Also, if you have blue Sphero Mini cables around, don’t use them. They are power-only cables with no data wires.

I hope you get this message in time to use it, or you found a solution already.

Jim

Thanks, Jim! My students and I appreciate any help! We finally have the micro:bit controlling the RVR to play PacMan! It is not perfect, but we think the middle school students can code it in time to play a game of PacMan.