Not charging

My SPRK+ isn’t holding a charge anymore, and I feel like I’ve tried everything, and I always make sure it’s charged up before using.

Does anyone have any tips on bringing it back to life?

Hi,

I’m sorry to hear about your charging issues! First and foremost, you should always be sure to let your Sphero’s battery die all the way (or at least as close to all the way as you can) before charging it up again. This helps prolong the robot’s battery life! Now, in the meantime, can you try the below steps?

  • Confirm you’re charging the robot with the heavy side down. If you’re not positive which side’s the heavy side, just set the robot on the counter and let it settle.

  • Be sure the charger is blinking blue when the robot’s set on the base (it’ll turn solid when it’s done charging).

  • Each generation of Sphero’s robotic ball comes with its own charging base. Please be sure you’re not trying to charge your SPRK+ with a SPRK or Sphero 2.0 charger

  • If it’s still not holding a charge after confirming the above steps, please try plugging your charger into a different power source and try charging again.

If it’s still struggling, please reach out to our support team at support@sphero.com for more help.

I had the same problem with my Sphero 2.0 and sadly I never got it to turn on after a wile so I cut it open and I found out that the battery’s where puffy and it was unable to hold a charge anymore.