RVR ALWAYS in Idle Mode when Micro-bit connected...

My son is trying to accomplish this project:

And he’s got the Micro-bit working correctly. As the program runs and you randomly press buttons you’ll get an X or a checkmark.

However, when we connect to the RVR and then power on the RVR it does 2 quick flashes of lights and then goes right into the alternating purple and blue lights indicating it is in Idle Mode. But the Micro-bit is still running the program. For the life of me I cannot figure out what we are doing wrong.

And yes, we updated the firmware in RVR to the latest version as of yesterday.

We also tried the basic project located here:

And while the Micro-bit displays the temp, the RVR still is in Idle Mode when the Micro-bit is connected.

I am sure there is a stupid simple solution here but I have yet to find it. Please help!


Hello @CobraKai!

So sorry to hear you are having some issues with the project.
This might be a silly question, but do you know if the USB cable you are using to connect the RVR and the Micro:Bit supports data? Is that the same cable that was used to program the Micro:Bit from your computer?
Also, have you tried using the Sphero EDU app to make sure your RVR is working properly?
Another thing you could do is to create a simple program through the MakeCode interface. You would just need to download the RVR extension.

I hope some of those things will work for you!


The USB cable is the one supplied from Sparkfun in the kit. Yes it is the same cable that we plug into the computer (to flash programs and power the Micro:Bit) and the robot.

My son just completed the RVR color block program today through the app and I watched the LEDs change color and then strobe at the end as it rolled over all 5 squares.

We tried the temperature sensor program through the MakeCode interface and that program also doesn’t load to the RVR but the Micro:Bit has no issues displaying the temp as it should. The RVR still stays in Idle Mode and doesn’t change color like it is supposed to.

Thanks for your quick reply. Let me know what else I can try.

Does adding the block ‘wake’ help at all?
Do you have another USB cable you can try?

You can also try to have a Micro:Bit program send drive commands in the loop forever block with a delay, while your RVR is connected to the EDU app and see if it does anything.

If that doesn’t work, I would reach out to customer support.
I hope this works!