RVR Firmware Checking

Hello,
I am using a Raspberry Pi and the Python SDK and Python version 3.7 with my RVR and every time I try to run a sample program, the pipenv shell says Checking RVR firmware versions… for a few seconds and the program ends. Nothing happens. I have manually updated RVR’s firmware and still, nothing happens. Not sure what the issue is but I hope to get RVR up and running with the SDK soon!

Thanks

1 Like

Hey @Mike!

I am so sorry that is happening; that sounds really frustrating, especially when you want to play with your new toy!

When you say you manually updated the RVR’s firmware, did you do that by connecting to the Edu app or via another method?

How are you running the samples? (Are you referring to the “samples” on our How To pages on sdk.sphero.com, which are also in the getting_started directory in the raspberrypi-python repo?)

It sounds like the issue is likely at the root (with the install of the firmware), but it could also be that the way in which you are running the programs is getting RVR a little out of whack… When I run the program, I am doing so in the terminal by cding into the getting_started directory and then, for example, cding into observer/driving and then running

python drive_with_heading.py

When doing so, I do not get any feedback in the terminal, the program just “thinks” for a second and then runs.

Looking forward to getting to the bottom of this with you!

Kelsey

1 Like

I also get a message ‘checking firmware version’ every time the python script starts (using demo apps). The app runs afterward, but just weird that it runs the check everytime the app runs.

1 Like

Thank you for that feedback!

The app does check the firmware of your robot every time it connects, to make sure it doesn’t need to be updated, but it is good for us to know that being alerted of that every time is a nuisance for you.

Thanks for being a part of our community!!

Kelsey

1 Like

Thanks for the reply,
I downloaded the sdk zip file onto a pi 3. I ran the first_time_setup.sh file then created a pipenv environment using python 3.7. I used pipenv install to install the dependencies in the PipFile. I then cd ed into the getting_started/observer/driving folder to run drive_raw_motors.py, for example. and the output I got is:
“Checking RVR Firmware Versions…” while the program is “thinking” as you put it and then the program ends. I am wondering what source the problem is coming from, the Pi not sending the command out, or the RVR not recieving the command? I went through the tutorial for Raspberry Pi setup and I triple- checked my wires, made sure the serial port was enabled and the serial console disabled.

Thank you for the reply Kelsey and I hope to get this problem solved!

Mike

1 Like

Hey Mike!

Thanks for that extra info :slight_smile:

When I do as you did, I get the following:
image
and, once the checks are finished, the treads on my RVR begin to spin.

Do you get to “Checking CMS firmware versions…”?
If not, it sounds like you need to connect your RVR to the mobile Edu app again (sorry, the desktop app doesn’t yet have the capability to do FW updates on your RVR) to make sure that the firmware on your bot is up to date, as the program seems to be failing at that stage.

:crossed_fingers: I hope this helps!

Kelsey

1 Like