Sphero Bolt Disconnecting

Hi,

I recently purchased two Sphero Bolts for Christmas presents and am encountering connection dropouts. I have detailed below the issues and what I have tried.

Issue:

  • both Sphero Bolts’ connect to iOS devices and operate normally for a random amount of time but generally no longer than about 2 minutes until they will disconnect and get an error message saying:

“Bluetooth disabled: Please turn on Bluetooth to connect to a robot”

If I am quick I can swap apps to the iOS Setting/Bluetooth page and see that the Bluetooth switch has turned itself off and then turns back on again.

Troubleshooting:

Did not work:

  • have tried on 2 different iPhones and 2 different iPads running iOS 14.3 and iPadOS 14.2

  • have tried in different houses to rule out house specific interference

  • have tried turning one Sphero completely off and just connecting one at a time to rule out inter-sphero interference

  • have tried turning Bluetooth off and on again on each iOS device, and have also restarted those devices with a hard reset.

  • not experiencing any bluetooth connection difficulties with other devices such as Apple Watch or portable bluetooth speakers.

  • have force updated the firmware on Sphero Bolt to firmware version 4.2.41, 4.2.44

Did work:

  • I have tried them on a Macbook Pro running Big Sur 11.1 and both appear to work fine and have not yet experienced any dropouts.

It would seem like I am having a problem with just iOS and iPadOS 14 and the Sphero. Is this a problem anyone else has seen before or any ideas on what to try next as obviously carting around a laptop to play with them is more of a hassle than operating them with an iPhone.

I have emailed support on Jan 3rd but no reply as yet, so hoping for some help here.

Thanks :slight_smile:

2 Likes

I am having the same issue in my classroom with my Power Pack and student iPads. It seems to be an iOS/iPad OS 14 issue.

At least I know it’s not just me. Hopefully the devs work out a fix soon!

Super disappointed that there has been no update on this issue. My school owns multiple packs and we have been having this same issue and it is March :frowning: We’ve tried updating the firmware, ensuring our iPads are updated, Bluetooth is on for both the app and the iPad, but no go. We love our Bolts but aren’t able to use them. Sphero please help!

Hi, I received this update from the Sphero team about a week ago on the issue. At least it seems they are getting closer to a solution. This was the text of the email.

"Hi there,

You are receiving this email because you have contacted Sphero Support regarding frequent connection errors when using your robot with your iOS device. Thank you for your continued patience as we work to resolve the connection issues.

We have been working closely with Apple and they are aware of the issue and have identified a fix for the frequent disconnect issues related to bluetooth. Apple hasn’t given us timing, but we’re expecting it to be resolved in an upcoming iOS update.

We know how frustrating this is and are anxiously awaiting the iOS update. We will continue to keep you informed as we hear more from Apple.

Thank you for your patience and understanding,"

SPHERO Email Marketing -