Unable to sign in to Edu App on Mac with google account

I can’t sign in to the Mac Sphero Edu App that is linked to my google account.
The error message from google is -
“You are trying to sign in from a browser or app that doesn’t allow us to keep your account secure.”

I have an Edu account and can sign in to the android app and webapp. Just not from the mac app.
Mac App: Version 5.3.0 (1285)

Any tips?

thanks

1 Like

Hey @jasonb!

So sorry to hear you’ve hit a wall :confused:

Upon doing a bit of googling on the error message you are getting, it looks like Google recently upgraded their security requirements for third-party sign-ins (to prevent man-in-the-middle attacks). I am checking in with our app team to see if they have any suggestions as to how to get you back up and running quickly, as I have not yet been able to reproduce the error you’re seeing.

Thank you so much for letting us know you’re running into this; I’ll let you know as soon as I hear anything :relaxed:

Kelsey

1 Like

Thanks for looking into this.
I’ve also got a case with support, though they haven’t found a workaround yet.

J

2 Likes

I downloaded the app from Google Play store to my Chromebook. When I try to click anything on that page like “sign in with Google” or Clever or guest or simply “sign in”, nothing happens! I need to make sure Chromebooks will talk to the RVR before we invest lots of $$ in them.

1 Like

Maybe try this: When clicking the Sign in With Google button, make it open a google chrome popup to sign in. Good suggestion?

1 Like

Was there any resolution to this problem? I also cannot use my Google login to sign into the Sphero app on Mac. I train teachers and students how to use Sphero, but it’s hard to model on a computer when I can’t connect.

1 Like

I’ve logged a case with Support, but have not seen a fix yet.

Jason

1 Like

Are you using a personal Gmail account OR an Enterprise account linked to a school district when you try and sign into the EDU Drive app on your Mac? On a whim, I tried logging into the Sphero EDU Mac app using the gmail account from my former school district. I was surprised to find that I was able to login and control the device using the Mac app on my MacBook with no problems. If you have a school email account (instead of personal), give it a try.

I’ll let you know when I hear back from Sphero on granting access to the EDU App with my personal account. I’ve left my district and my Leave of Absence access ends soon, so I don’t will only have access to a personal account.

1 Like

Personal. I’ve tried both with and without 2FA.
regards
Jason

1 Like